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[1.0.0] System Requirements
For a good preformance of Smart Poly you should use a Sytem betwen
“Minimum” and “Recomended”. Because of the multiple System settings
sometimes Smart Poly can work slow also at “Recomended” systems.

[1.1.0] Minimum
Mouse & Keyboard
Pentium 1; 800 Mhz 
64 MB RAM
Voodoo 2
Windows98 
Microsoft DirectX 8 
Approx. 20 MB of free memory 
Write access to the "Smart Poly" folder!

[1.2.0] Recommended
Mouse & Keyboard 
Pentium 3 - 2200 Mhz 
512 MB RAM 
GeeForce 3 
WindowsXP + Servicepack1 
Microsoft DirectX 9 
Approx. 20 MB of free memory 
Write access to the "Smart Poly" folder!
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[2.0.0] Startup with Smart Poly
[2.1.0] What is Smart Poly? 
Smart Poly is a 3d modelling tool for creating simple 3d Objects in the
GML format (Game Maker language). You can create complex models and
export your creation in a few steps as Primitive or Model code. Also you
can use Texture Materials and Color Maps and export their settings too.
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[3.0.0] Menu Interface
[3.1.0] File menu
In the File menu you find all functions that deal with external files. Smart
Poly can load and save files *.scr (Smart Poly Scene) and Import and
Export Files as *.txt (Textfile) or *.gml (Game Maker language).

New Scene Creates a new Scene in the 'free' view. 
(shortcut: F,N)

Open Scene Opens a saved Smart Poly Scene file (.scn). 
(shortcut: F,O)

Recent Files If you have already saved some Smart Poly
Scenes, in this action will show a button for
each file. Normaly 10 files will saved.

Save Scene Saves Scene file under its current name. If no
name was specified before, you are asked for a
new name. (shortcut: F,S)

Save Scene as Saves the Scene file under a different name.
You are asked for a new name. (shortcut: F,A)

Export Scene Will export the current Scene as GML-code to
the indicated folder. (shortcut: F,E) 

Exit Smart Poly Will end Smart Poly after a dialog.
(shortcut: F,X)
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[3.2.0] Edit menu
The Edit menu will change by the Editmodus is choosen. You can switch
between the Modus “Dummie”, “Vertex”, “Primitive” and “Extended”.

[3.2.1] Edit menu Dummie
Change X

Change Y

Change Z

Lock/Unlock

[3.2.1] Edit menu Vertex
Change X

Change Y

Change Z

Set X Map

Set Y Map

Set Alpha

Set Color

Change Group

Lock/Unlock
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[3.2.1] Edit menu Primitive
Change X

Change Y

Change Z

Set X size

Set Y size

Set Z size

Set X rotation

Set Y rotation

Set Z rotation

Set X scaling

Set Y scaling

Set Z scaling

Set X translation

Set Y translation

Set Z translation

Hor. texture repeat

Ver. texture repeat

Set Alpha

Set Color

Set Texture

Set Segments

Set Closed

Set Type

Lock/Unlock
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[3.2.1] Edit menu Extended
Change X

Change Y

Change Z

Set X size

Set Y size

Set Z size

Set X rotation

Set Y rotation

Set Z rotation

Set X scaling

Set Y scaling

Set Z scaling

Set X translation

Set Y translation

Set Z translation

Hor. texture repeat

Ver. texture repeat

Set Alpha

Set Color

Set Texture

Change Code

Lock/Unlock
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[3.3.0] View menu
Camera Free This action loads the Free Camera settings. The

Camera shows an isometric view of the current
Scene. (shortcut: V,F) 

Camera Left This action loads the Left Camera settings. The
Camera shows an planar view of the current
Scene. (shortcut: V,L) 

Camera Right This action loads the Right Camera settings.
The Camera shows an planar view of the curr-
rent Scene. (shortcut: V,R) 

Camera Top This action loads the Top Camera settings. The
Camera shows an planar view of the current
Scene. (shortcut: V,T) 

Camera Bottom This action loads the Bottom Camera settings.
The Camera shows an planar view of the curr-
rent Scene. (shortcut: V,B)

Hide all Dummies This option will remove all Dummie objects from
the scene for the moment. 

Hide all Vertex This option will remove all Vertex objects from
the scene for the moment. 

Hide all Primitives This option will remove all Primitive objects from
the scene for the moment. 

Hide all Extended This option will remove all Extended objects
from the scene for the moment. 

Hide all Objects This option will remove all objects from the scene
for the moment. (shortcut: V,H) 
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Unhide all Dummies This option will show all hidden Dummie objects
in the scene. 

Unhide all Vertex This option will show all hidden Vertex objects in
the scene. 

Unhide all Primitives This option will show all hidden Primitive objects
in the Scene. 

Unhide all Extended This option will show all hidden Extended objects
in the Scene. 

Unhide all Objects This option will show all hidden objects in the
Scene. (shortcut: V,U)
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[3.4.0] Settings menu
Vertex Group Color Set a Color for the indicated Vertex-Group

used when the Group has no Color Map.

Vertex Group Alpha Set a global Alphavalue for the indicated
Vertex-Group, used for all Vertex-Objects
in the Group

Vertex Group Texture Set for the indicated Vertex-Group, a
Background Texture, a Sprite Texture or
no Texture.

Vertex default Group Indicated the Group-Number, new Vertex-
Objects get when created.

Vertex Group Pointlist The Vertex Objects in the current Scene
will form a pointlist, in the range of their
creation. 

Vertex Group Linelist The Vertex Objects in the indicated Group
will form a linelist, in the range of their
creation. 

Vertex Group Linestrip The Vertex Objects in the current Scene
will form a Linestrip, in the range of their
creation. 

Vertex Group Trianglelist The Vertex Objects in the indicated Group
will form a Trianglelist, in the range of
their creation. 

Vertex Group Trianglestrip The Vertex Objects in the indicated Group
will form a Trianglestrip, in the range of
their creation. 

Vertex Group Trianglefan The Vertex Objects in the indicated Group
will form a Trianglefan, in the range of
their creation.
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Vertex Group No Map For the indicated Vertex-Group will set no
Color- or Texturemap.

Vertex Group Color Map For the indicated Vertex-Group will set a
Colormap using the Colors of the Vertex-
Objects in the Group.

Vertex Group Texture Map For the indicated Vertex-Group will set a
Texturemap using the Texture set for the
Group with the UV values of the Vertex-
Objects in the Group

Vertex Group All Maps Using Color- an Texturmap for Drawing
indicated Vertexgroup.

Load Texture as sprite This action let you, to choose one of ten
avalible Sprite Texture slots. Then to
choose an external BMP, JPEG or GIF file
to load for it. 

Load Texture as Back... This action let you, to choose one of ten
avalible Background Texture slots. Then
to choose an external BMP or JPEG file
to load for it.
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[3.5.0] Options menu
Polygone Edged Faces This functions draw the Polygones of the

Vertex Groups a second time as an
Outline. This function is a little slow!

Polygone Wireframes This functions will draw the Polygones of
the Vertex Groups only as an Outline.

Polygone Culling This functions will activate and deactivate
the Culling. Backsides of Polygones will
not be visible when Culling is activated.

Camera Scrolling Speed This action will ask You to change the
Camera Scrolling speed. The default is
"3". This is the Speed for the movement
of the Camera.

Camera Selection Range This action will ask You to change
Camera Selection Range. The default is
"20". This is the Range for manipulate
objects with the cursor.

Camera Gizmo Size This action will ask You to change
Camera Gizmo Size. The default is "25".
This is the Size the Transform Gizmos
drawn by manipulating objects. 
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World Grid Show This action will hide or unhide the Grid.

World Grid Snap This action will activate and deactivate
the Grid-Snapping Function for the Scene.

World Grid Size This action will ask You to change World
Grid Size for the Scene. The default is
"200". This is the Size the world girid is
drawn in the view. The Camera settings
will react on changes.

World Grid Unit This action will ask You to change World
Grid Unit for the Scene. The default is
"10". This is the number of Units the
World Grid is divided into.

World Fog Show This action will activate or deactivate the
World Fog for the Scene.

World Fog Range This action will ask You to change the
World Fog Range for the Scene. The
default is "1000".

World Fog Color This action will change the Fog Color for
the Scene.

World Background Color This action will change Background Color
for the Scene.
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Export Type Settings Here You can indicate, that the Scene
should be exported as Primitive or Model-
Code. The Model-Code is only usefull for
Game Maker 6.1.

Export with XYZ string Here You can indicate, that the objects
should be exportet with x, y, and z strings
in the Functions. If the Function is activa-
ted Smart Poly will export “Smart-Code”.
Otherwise “Static-Code” will be exported.

Export as Identity Here You can indicate that all Objcets
should be Identitys, the full code set as
Identity or not Identity-Functions used to
export code.

Export Index Name Here You can change the Name of the
Model-Index, used by exporting Scene as
Model-Code.

Export Filetype Here You can indicate, that the Scene
should be exported as .txt or .gml file.
When .gml format is choosen, some
extra lines for importing the script in the
Game Maker will be created.

Window Fullscreen This action switch between the Fullscreen
and the Windowmodus. If the Fullscreen-
modus is choosen the Windowsize will be
ignored.

Window Default With this action you can load the Window
default settings. Normaly the windowsize
is 800x600 pixel and is centered on the
screen.

Set Text Editor Here You can choose a Text Editor, used
for Editing drawcodes etc. The default is
the Notepad.exe, included in Windows©.
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[3.6.0] Plugins menu
In the Plugins menue, all Pulgins installed to the Smart Poly Engine will
appear. Note that the Pugin-Actions saved with the Smart Poly Scene.

How to Install a Plugin?
Simple extract all Files, incuded in the Arcive, to the
“Plugin”-Folder, stored defaultly in the “data” Directory.
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[3.7.0] Help menu
Smart Poly Manual This action will load this Manual.

Smart Poly Keyboardmap This action will show the Keyboardmap
with all Shortcuts of Smart Poly.

Smart Poly ReadMe This action will open the Smart Poly
Readme.txt file, stored in the Main direc-
tory.

Smart Poly Website This action will open the Smart Poly web-
site with the Mircosoft© “Internet explo-
rer”.

VectorGames Website This action will open the VectorGames.de
website with the Mircosoft© “Internet
explorer”.

About Smart Poly This action will show a Window with some
Informations about Smart Poly.

———————————————————————————————————————————--
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[4.0.0] Toolbar Interface
[4.1.0] Modification Tools
Creation Tool The Creation Tool changes with the Edit Modus.

It will Change the icon for the Modus is choosen
(There are the Modi: Dummie, Vertex Primitive
and Extended). (Shortcut: C)

Movement Tool With the Movement Tool you can move all
selected objects in the activated Axis (X,Y, and
Z). While the Grid Snapping Option is activated,
the Objects will move snaped to the indicated
Grid. (Shortcut: M)

Rotation Tool With the Rotation Tool you can rotate the
Objects in the Selection in the indicated Axis. 
(Shortcut: R)

Sizing Tool With the Sizing Tool you can change the Size of
the Objects in the Selection in the indicated
Axis. (Shortcut: I)

Scaling Tool With the Scaling Tool you can change the
Scaling-Factor of the Objects in the Selection in
the indicated Axis. (Shortcut: L)

Lock X Axis When Lock X Axis is Activated all Tools will
Modify the x values of the Objects in the
Selection. (Shortcut: X)

Lock Y Axis When Lock Y Axis is Activated all Tools will
Modify the y values of the Objects in the
Selection. (Shortcut: Y)

Lock Z Axis When Lock Z Axis is Activated all Tools will
Modify the z values of the Objects in the
Selection. No other Axis can modified whit the Z
Axis. (Shortcut: Z)
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Grid Snapping This Tool will activate and deactivate the
Grid-Snapping Function for the Scene.
(Shortcut: G)

Default Color This Tool will change the Color, that is
used for creating new objects in the
Scene. (Shortcut: D)

Edit Dummies Will change modus to “Edit Dummies”.
Now only Dummie objects could be selec-
ted and modified.

Edit Vertex Will change modus to “Edit Vertex”. Now
only Vertex objects could be selected and
modified.

Edit Primitives Will change modus to “Edit Primitives”.
Now only Primitive objects could be
selected and modified. Note that you can
open a small menu to indicate the type of
Primitive should be created with the
Creation-Tool.

Edit Extended Will change modus to “Edit Extended”.
Now only Extended objects could be
selected and modified.

UV Map Editor Will open the Vertex Group UV Map
Editor, to edit the UV values (x and y
Mapping). (Shortcut: U)

Render Scene Will render a bitmap of the Scene and
save it in the Renderings Folder. With a
dialog you can delete the Image.
(Shortcut: F10)
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[ 19 ]
———————————————————————————————————————————



[5.0.0] The Key Allocation 
Smart Poly has a lot of functions you can call by pressing one ore more
keys simultaniously. This is called a Shortcut. Its usefull to know some of
these Shortcuts to have a good workflow. Some of the functions, executed
with a Shotcut, can also called with a menu or a Toolbar icon, but the use
of shortcuts is very much faster.

[5.1.0] Engine Shortcuts (green)
N + Control Creates a new Scene after a dialog.

S + Control Saves the current Scene. If no name was set
before, you will be ask for a filename.

S + Shift Will open the “Save Scene as” dialog. You will be
asked for a filename the Scene will be saved as.

O + Control Will open the dialog to open a Scene.

E + Control If the scene is saved, the Export dialog will start.

Q + Control Will end Smart Poly after a dialog.

F1 This action open the Smart Poly Helpfile.

F3 Switch between the Fullscreen- and the Window
mode.

F9 Saves a Rendeing of the Scene, normaly in the
folder “Images\Renderings”.

F10 Saves a Screenshot of the Scene, normaly in
the folder “Images\Renderings”.

F12 Will open or close the Console. Note that the
most shortcuts won´t work in Cosole modus!
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[5.1.0] Menu Shortcuts (yellow)
F Will open the File menu.

E Will open the Edit menu.

V Will open the View menu.

S Will open the Settings menu.

O Will open the Options menu.

H Will open the Help menu.

[5.2.0] Toolbar Shortcuts (blue)
C Actives the Creation Tool.

M Actives the Movement Tool.

R Actives the Rotation Tool.

I Actives the Sizing Tool.

L Actives the Scaling Tool.

G Actives or deactives the Grid snapping.

D Change the default Color.

X Actives or deactivates the X Axis.

Y Actives or deactivates the Y Axis.

Z Actives or deactivates the Z Axis.
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[5.3.0] Camera Shortcuts (cyan)
Arrow up Moves Camera forward. 
Arrow down Moves Camera backward. 
Arrow left Moves Camera left. 
Arrow right Moves Camera right.

Arrow up + Shift Rotate camera up. 
Arrow down + Shift Rotate camera down. 
Arrow left + Shift Rotate camera left. 
Arrow left + Shift Rotate camera right. 

Arrow up + Control Moves Camera in the z axis up. 
Arrow down + Control Moves Camera in the z axis down. 
Arrow left + Control Rotate camera left around the scene. 
Arrow left + Control Rotate camera right around the scene. 

Spacebar Will the Camera let follow the cursor

G + Control Will show or hide the Grid.

F4 Loads the “Free” Camera settings.

F5 Loads the “Left” Camera settings.

F6 Loads the “Right” Camera settings.

F7 Loads the “Top” Camera settings.

F8 Loads the “Bottom” Camera settings.

[5.4.0] Object Shortcuts (red)
A + Control Select all of the current Edit Modus type in the

Scene.

D + Control Unselect all of the current Edit Modus type in
the Scene.

C + Control Creates “Clone”-Objects of the selected Objects.
The Clones will have the same Propperties as
the Parent Objects.

Delete Will delete all selected objects in the Scene
after a dialog.
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[8.0.0] Smart Poly License
The program which can be installed you "as it is" to the order posed,
without guarantee any kind, neither expressly nor implicitly. The entire risk,
which results from using or the achievement of the program, remains
with you. The manufacturer does not take over any guarantee for this soft-
ware. He takes over in particular no adhesion for the fitness, the suitabili-
ty for a certain purpose and the not injury of the rights third. 

With the installation of the program and the using of the program you
agree the use regulations of the present treaty. If you reject these regu-
lations, you may install the program neither, change or the program to
use. By instalation of the program you commit yourselves for the
adherence to the conditions of the present treaty. If you do not agree with
the conditions of the present treaty, remove all components of the pro-
gram from your computer.

Please you read first the following conditions of this license agreement,
before you accept them.

The use and execution of the program which can be installed take place
on own risk. The author is not responsible for damage of material, econo-
mic or idealistic kind, which could have resulted from the use of the pro-
gram. During the composition of the programming codes with largest
care one proceeded. Nevertheless errors can be not completely excluded.
The author can take a legal responsibility nor any adhesion for incorrect
data and their consequences neither. For improvement suggestions,
points of criticism and referring to errors the author is grateful. Any devi-
ation of the conditions of this license agreement requires the written con-
firmation by the author. The program author can be made not liable for
jedweden arising damage or damage, which results from the use of the
software. The employment of the program happens without reservation
on exclusive responsibility of the final user. In no case the manufacturer
can be made liable for damage, which developed from loss of use, loss of
data or escaped profit to result and by this software or in connection with
the use of this software.

© 2005 by VectorGames.de - All rights reserved!
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